PHP Compilation (Cannot find -lltdl)

When compiling PHP from source (in my case version 5.3.2) on CentOS 5.4 I kept getting the following error when trying to compile with mcrypt:

"/usr/bin/ld: cannot find -lltdl"

This seems to be due to a missing development library with the obscure name of libtool-ltdl-devel to fix this simply use:

yum install libtool-ltdl-devel

Which should include the package along with several dependencies.

libltdl3-dev

Leave a Reply

Your email address will not be published. Required fields are marked *